Category Archives: Errors

Css merge does not work

If you enable css merge and you find that your site does not look the same or the styles are wrong then the reason behind it might be the css @import. Remove the @import sections and add the imported css … Continue reading

Posted in Errors | Tagged , , | Leave a comment

Google analytics not working?

Have you inseerted Google API in the admin? Yes? That might be a simple issue. Check googleanalytics.xml of your template. If you see something like <block type="googleanalytics/ga" name="google_analytics" as="google_analytics" /> Bingo! The reference to the template file is missing! Change … Continue reading

Posted in Errors, Uncategorized | Tagged , | Leave a comment

Email a friend does not send mails with Amazon SMTP

If you have installed Aschroder SMTP module and happen to have an Amazon SMTP server and you’ve noticed that only email a friend does not send mail then the problem is with the SMTP server. If you check your error … Continue reading

Posted in Errors, Uncategorized | Tagged , | 6 Comments

Magento causes internal server error 500

In magento 1.7 this can be caused by disabled track and trace in the htacces file ## TRACE and TRACK HTTP methods disabled to prevent XSS attacks RewriteCond %{REQUEST_METHOD} ^TRAC[EK] RewriteRule .* – [L,R=405] Comment out the last two lines … Continue reading

Posted in Errors | Leave a comment

Block class override

If you happen to install  Creare Mass Landscape Shipping Label  and  Simple Order export  free modules  you will have the nasty surprise that in the orders actions menu  will not show up Print landscape shipping labels .  This is due to … Continue reading

Posted in Errors, Uncategorized | Leave a comment

Exception message: Invalid method Mage_CatalogSearch_Model_Query::loadByQueryText

In magento 1.6  this caused by overriding with an older model local  in /app/code/local/Mage/CatalogSearch/Model

Posted in Errors | Leave a comment

Error Source model “customer_entity/address_attribute_source_country” not found for attribute “country_id”

If you happen to encounter this error in magento 1.6 there is a chance that was caused by an upgrade from a previous version of magento.  Check eav_atribute table and change rows containing customer_entity/address_attribute_source_country customer_entity/address_attribute_source_region to customer/entity_address_attribute_source_country customer/entity_address_attribute_source_region Also if … Continue reading

Posted in Errors | 4 Comments

Magento search gives 404 page

If you happened to notice that simple search results with  404 page (page not found) for Magento 1.4 , check if you have installed  Customers who bought this product also purchased magento extension. The fix is pretty simple. Open app/code/local/Jain/Bought/etc/config.xml … Continue reading

Posted in Errors, extensions | Tagged , , , , | 3 Comments